Forum

Share:
Notifications
Clear all

Regen or what?

Page 1 / 2

stechr
Posts: 5
Topic starter
(@stechr)
Active Member
Joined: 1 month ago

Hi.

 

I have a tc that feels like regen is kicking in many times during a 20min drive. When i have full throttle. Its just for a split seckond, but i lose speed. And its really f... anoying.  Its been like this since day one and with both 1 and 2 batteries. Software update made it brake even harder. Does anyone else have this problem? And what to do?

9 Replies
RZEE
Posts: 6
 RZEE
(@rzee)
Active Member
Joined: 5 months ago

What is the maximum speed of your bike ?

Reply
arjan_1980
Posts: 36
(@arjan_1980)
Eminent Member
Joined: 3 months ago

I am wondering, as far as i understand regen only kicks in when the brake is applied, maybe try disconnecting one of the brake switches at the time to see if the problem is cured.

Reply
stechr
Posts: 5
Topic starter
(@stechr)
Active Member
Joined: 1 month ago

Thanks for replys. But i have claimed my money back. Had so much problems since i bought it in okt. Gonna try the tsx and hope its better.

Reply
1 Reply
OchAye
(@ochaye)
Joined: 5 months ago

New Member
Posts: 4

@stechr It’s the same bike with different styling. regen only happens when the motor is slowing you down and the throttle is open (i.e. going downhill faster than the max speed for the mode you’re in), not under braking.

Reply
stechr
Posts: 5
Topic starter
(@stechr)
Active Member
Joined: 1 month ago

I know its the same bike. But i has to come with less problems then the tc. 

And when i say regen kicks in, it just feels like it does. Its like its loosing power while driving and it brakes for a split second. While driving at all speeds, not only max speed. I also had my brakes locked, so they been replaced 2 times. The cables to the battery changed. And know my front tire is loose and there is small rocks in the wheel baring or something. The sound is so f.... loud 🥴 but the bolt is tight tho. Even the blinkers had problems, and the brake lights. And the fun part is, i had to fight with the dealership to get it fixed 🤦‍♂️

Reply
Page 1 / 2
Share: